销售站 - 一站式品质服务平台,一体化商城系统.

24小时服务电话

134-2860-6060

查看: 484|回复: 0

[图文教程] Discuz!应用中心安装模板提示版本号不匹配的解决方法

[复制链接]
发表于 2017-5-7 22:14:17 | 显示全部楼层 |阅读模式
填写您的邮件地址,订阅我们的精彩内容:
[受理编号:SL-2493]
填写您的邮件地址,订阅我们的精彩内容:
有时候我们从应用中心安装模板,在应用中心里模板作者设定允许我们的程序版本,但是我们安装时却提示版本号不匹配,那这是为什么呢?

经过我们分析发现是因为X3和X3.1,X3.2的模板是完全兼容的,很多模板是在X3的时候发布,而且之前的机制里一直是即使版本号不同,用户依然可以强制安装,但是,从X3.1后期开始,官方自己把自己的规矩改了,用户没有办法强制安装了,很多作者也没有在意这点,而且应用中心模板的审核与发布、更新的周期更让作者们苦等。

下面我们以discuz! X3的qing模板安装在X3.2上为例子讲解。


首先说的是错误提示图,如下图所示,官方发布的升级版版本号还是X2.5的,不过这不影响我们演示:




我们打开template/qing(其他模板为其他模板的目录)/discuz_style_qing.xml文件,在里面找到X2.5,

如果错误图提示为什么版本就搜什么版本,通常能搜索到至少两处


修改成自己的版本然后保存,重新在后台,界面,风格设置处安装模板即可。



本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?立即注册

x
回复
〖销售站〗一站式品质服务平台. 一体化商城系统.【www.xiaoshouzhan.com】
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

销售站-一体化商城系统!
 
 
Q Q|技术部
销售|销售部
客服|销售站实体店
分流|销售站实体店
视频解析群:
好记吧
产品售后群:
站长源码(交易平台)
域名拍卖群:
域名拍卖群
产品维权群:
藤县站
微信客服中心:
/images/niwota00000000300.jpg
工作时间:
8:00-18:00
 
版权所有:销售站

QQ|关于我们|手机版|( 粤ICP备16099612号-2|网站地图  | Sponsor: 好记吧物联网